CipherOwl Services in aws::us-east-1 is down

Incident Report for CipherOwl - System

Resolved

The incident is resolving on the cloud provider's side.We are seeing all APIs able to call correctly.
Posted Oct 20, 2025 - 10:15 UTC

Monitoring

The cloud provider outage seems to be recovering. We are monitoring recovery, and are seeing signs that customers can produce and fetch correctly
Posted Oct 20, 2025 - 10:03 UTC

Identified

We have confirmation the issue is due to an AWS outage in us-east-1.
Posted Oct 20, 2025 - 08:05 UTC

Investigating

One of our downstream dependency is down and therefore our services are all down.
Posted Oct 20, 2025 - 07:30 UTC
This incident affected: Sanctioned Address API, Risk Score API, and Investigation Tool.